Meine Abenteuer mit Upgrade auf Windows 10

Nachdem mein Arbeitsrechner diverse Probleme hatte, habe ich mich zu einem Upgrade auf Windows 10 Enterprise entschlossen. Dies ging dann noch wesentlicher angespannter über die Bühne als gedacht. Einige Fehler habe ich schlicht selbst verschuldet, bei einigen ist mir die Ursache bis heute nicht ganz klar. Dieser Blogartikel soll die Fehler benennen und dafür mögliche Lösungen aufzeigen. Vielleicht hilft es ja den einen oder anderen. Ich habe mich bemüht, dabei die chronologische Reihenfolge der Fehler einzuhalten.

Falsche Version im Download

Ich habe mir Windows 10 aus meinen MSDN Abo als MCT Trainer gezogen. Dabei ich zuerst die 32 Bit Version heruntergeladen, obwohl ich ja ein 64 Bit System habe. Typischer Fehler von meiner Seite. Das Setup sagt dann auch brav, das es ein Update nicht ausführen kann.

Kein Installation möglich, weil Windows angeblich auf USB Stick installiert

Nach dem Herunterladen des richtigen Installationsmediums überraschte mich das Setup mit einer interessanten Meldung: Windows 10 kann mit Hilfe von Setup nicht auf einem USB-Speicherstick installiert werden.

Natürlich ist dies nicht der Fall, mein Windows 8.1 wurde auf einer internen Festplatte installiert. Aber, und das ist wahrscheinlich die eigentliche Ursache des Fehlers, das Betriebssystem ist auf die Festplatte gekommen, weil ich per Image dieses von einem anderen Laptop geklont habe. Das Klonen hat einen Registry Eintrag verursacht, mit dem das Setup einfach nicht umgehen konnte.

Um das Problem zu lösen, öffnen Sie den Registrierungseditor und gehen Sie zu dem Schlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control. Suchen Sie dort den DWORD-Wert PortableOperatingSystem. Dieser sollte den Wert 1 haben, das Setup erwartet aber 0. Ändern Sie den Wert entsprechend.

Danach ist das Setup ohne Probleme durchgelaufen und die Anmeldung erschien. Doch dort lauerte der nächste Fehler.

Keine Anmeldung an Windows 10 möglich, angeblich ist das Passwort falsch

Voller Freude in der Anmeldung mein Passwort eingetippt und die Meldung bekommen, dieses wäre falsch. Nun gut, beim ersten Mal kann dies passieren. Noch einmal, noch einmal und noch einmal eingetippt und immer noch falsch. Auch die visuelle Kontrolle bestätigt: Dies ist mein Passwort. Aber nein, Windows 10 sagt, es wäre falsch. Ebenso werden mir die Netzwerkverbindungen als nicht funktionierend angezeigt. Es gibt auch kein alternatives Konto zum Anmelden.

Nach etlichen Recherchen scheint sich folgendes abzuspielen: Da ich mich an Windows 8.1 mit einem Microsoft Konto anmelde, wurde dies auch so von Windows 10 übernommen. Jetzt versucht Windows 10 einen Microsoft Server zu kontaktieren um herauszufinden, ob mein eingegebenes Passwort das richtige ist. Da aber das Netzwerk nicht funktioniert…

Es blieb mir nichts anderes übrig, ich bin zu Windows 8.1 zurückgekehrt und habe dann dort einen neuen lokalen Benutzer mit administrativen Rechten angelegt. Das Windows 10 Setup neu gestartet und siehe da, mit einem lokalen Konto funktioniert die Anmeldung. Bei meinen nächsten Migrationen werde ich immer ein lokales Konto vorher anlegen. Sicher ist sicher. Jetzt geht es als nächstes an das Netzwerk.

Kein Netzwerk mehr vorhanden

Nach der Anmeldung mit dem lokalen Konto ließ sich keine Netzwerkverbindung herstellen, egal auf welchen Kanal. Weder über Kabel noch über W-Lan. Ein Blick in die Adaptereinstellungen zeigte, dass alle Netzwerkverbindungen deaktiviert waren. Es war auch nicht möglich diese zu aktivieren. Der Versuch wurde ohne Kommentar und Fehler abgebrochen. Dazu muss man noch wissen, dass auf meinem Rechner Hyper-V aktiviert war, welches virtuelle Switche erstellt hatte. Diese virtuellen Switche waren das eigentliche Problem. Ich habe diese dann gelöscht, was aber immer noch keinen Erfolg gebracht hat. Logisch, denn in den realen Verbindungen war das komplette TCP/IP nicht gebunden. Nachdem ich dieses wieder gebunden und entsprechend konfiguriert hatte, war auch dieses Problem gelöst.

Ich habe dann das Hyper-V Feature deinstalliert, neu installiert und auch das ging wunderbar.

Neu aktivieren

Da es sich um eine Windows 10 Enterprise Edition handelt, musste ich auch den Produktschlüssel neu eingeben. Ein automatische Aktivierung erfolgte nicht.

Vielen Dank für Ihr Interesse an meinem Blogeintrag.
Gerne beantworte ich Ihnen persönlich weitergehende Fragen zu diesem Thema.
Kontaktieren Sie mich einfach über mein Kontaktformular.

Sie wollen mehr über mich erfahren? Dann gehen Sie auf meine Site
http://www.nicothiemer.de

Nico Thiemer

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s